CVE-2021-21353: Pug is an npm package which is a high-performance template engine. In pug before version 3.0.1, if a remote attacker wa…
Pug is an npm package which is a high-performance template engine. In pug before version 3.0.1, if a remote attacker was able to control the `pretty` option of the pug compiler, e.g. if you spread a user provided object such as the query parameters of a request into the pug template inputs, it was possible for them to achieve remote code execution on the node.js backend. This is fixed in version 3.0.1. This advisory applies to multiple pug packages including "pug", "pug-code-gen". pug-code-gen has a backported fix at version 2.0.3. This advisory is not exploitable if there is no way for un-trusted input to be passed to pug as the `pretty` option, e.g. if you compile templates in advance before applying user input to them, you do not need to upgrade.
- Published by source
- 2021-03-03
- First seen by Reality Radar
- 2026-11-02
- Last verified
- 2026-11-02
Affected
- Manufacturer
- pugjs
- Products
- pug pug-code-gen
- Versions
- <3.0.1 <2.0.3 <3.0.2
- CPE
- cpe:2.3:a:pugjs:pug:*:*:*:*:*:node.js:*:*
cpe:2.3:a:pugjs:pug-code-gen:*:*:*:*:*:node.js:*:*
Whether your exact unit is affected depends on the model, serial number and region in the official notice.
What the official notice says
Risk: critical severity (CVSS 9)
Is this affecting you?
Add what you own or use and Reality Radar will tell you when official changes match it — with evidence and next steps.
Sources
- NIST National Vulnerability Database Tier A · official published 2021-03-03
Evidence ledger
Every piece of evidence we store is appended to a public hash chain, so later edits are detectable. Anyone can re-verify it.
| Entry | Kind | Observed | Evidence hash | Entry hash |
|---|---|---|---|---|
| #3477 | new | 2026-11-02 | 2df6afa76748…94c69d | c2b59345ef21…5a479b |
Chain head: #3807 03071ef7d321…845940