CVE-2026-35569: ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain a stored cross-site…
ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain a stored cross-site scripting vulnerability in SEO-related fields (SEO Title and Meta Description), where user-controlled input is rendered without proper output encoding into HTML contexts including <title> tags, <meta> attributes, and JSON-LD structured data. An attacker can inject a payload such as "></title><script>alert(1)</script> to break out of the intended HTML context and execute arbitrary JavaScript in the browser of any authenticated user who views the affected page. This can be leveraged to perform authenticated API requests, access sensitive data such as usernames, email addresses, and roles via internal APIs, and exfiltrate it to an attacker-controlled server. This issue has been fixed in version 4.29.0.
- Published by source
- 2026-04-15
- First seen by Reality Radar
- 2026-10-27
- Last verified
- 2026-10-27
Affected
- Manufacturer
- apostrophecms
- Products
- apostrophecms
- Versions
- <4.29.0
- CPE
- cpe:2.3:a:apostrophecms:apostrophecms:*:*:*:*:*:*:*:*
Whether your exact unit is affected depends on the model, serial number and region in the official notice.
What the official notice says
Risk: CVSS 8.7
Is this affecting you?
Add what you own or use and Reality Radar will tell you when official changes match it — with evidence and next steps.
Sources
- NIST National Vulnerability Database Tier A · official published 2026-04-15
Evidence ledger
Every piece of evidence we store is appended to a public hash chain, so later edits are detectable. Anyone can re-verify it.
| Entry | Kind | Observed | Evidence hash | Entry hash |
|---|---|---|---|---|
| #2144 | new | 2026-10-27 | 1ba8e7477141…9b45f2 | d0dbc4260c83…b5d22f |
Chain head: #2286 e212558e872c…954bc1