CVE-2026-41636: Uncontrolled Recursion vulnerability in Apache Thrift Node.js bindings This issue affects Apache Thrift: before 0.23.0.…
Uncontrolled Recursion vulnerability in Apache Thrift Node.js bindings This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.
- Published by source
- 2026-04-28
- First seen by Reality Radar
- 2026-10-27
- Last verified
- 2026-10-27
Affected
- Manufacturer
- apache
- Products
- thrift
- Versions
- <0.23.0
- CPE
- cpe:2.3:a:apache:thrift:*:*:*:*:*:node.js:*:*
Whether your exact unit is affected depends on the model, serial number and region in the official notice.
What the official notice says
Risk: CVSS 8.7
Is this affecting you?
Add what you own or use and Reality Radar will tell you when official changes match it — with evidence and next steps.
Sources
- NIST National Vulnerability Database Tier A · official published 2026-04-28
Evidence ledger
Every piece of evidence we store is appended to a public hash chain, so later edits are detectable. Anyone can re-verify it.
| Entry | Kind | Observed | Evidence hash | Entry hash |
|---|---|---|---|---|
| #2157 | new | 2026-10-27 | b2efb8b6f088…e76f27 | 975534558ec4…86e2a8 |
Chain head: #2286 e212558e872c…954bc1