CVE-2026-44578: Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-h…
Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.
- Published by source
- 2026-05-13
- First seen by Reality Radar
- 2026-10-26
- Last verified
- 2026-10-26
Affected
- Manufacturer
- vercel
- Products
- next.js
- Versions
- <15.5.16 <16.2.5
- CPE
- cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*
Whether your exact unit is affected depends on the model, serial number and region in the official notice.
What the official notice says
Risk: CVSS 8.6
Is this affecting you?
Add what you own or use and Reality Radar will tell you when official changes match it — with evidence and next steps.
Sources
- NIST National Vulnerability Database Tier A · official published 2026-05-13
Evidence ledger
Every piece of evidence we store is appended to a public hash chain, so later edits are detectable. Anyone can re-verify it.
| Entry | Kind | Observed | Evidence hash | Entry hash |
|---|---|---|---|---|
| #1845 | new | 2026-10-26 | cf07a611d650…e89b99 | a93e10cccd35…76b8ac |
Chain head: #1913 68d492d71c09…880c23